Author Topic: Hotspot, T-Mobile SyncUP Not connecting  (Read 289 times)

0 Members and 0 Guests are viewing this topic.

Offline K2AMP

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Hotspot, T-Mobile SyncUP Not connecting
« on: May 12, 2020, 11:06:53 pm »
In my truck I have a recently acquired Jr Hotspot, from Robert, along with a T-Mobile SyncUP device that plugs into the OBD2 diag connector which provides WiFi for hotspot capabilities via TMo's LTE service. If I connect to the WiFi with my iPhone I'm able to hit any website I want. However, I am unable to communicate with my DMR HT on any TG. I have another, identical hotspot in my house that is attached to my Comcast internet service. Same HT can communicate flawlessly on any TG through that hotspot.

While troubleshooting the issue, I went to the Live Logs on the truck hotspot while attached to the TMo device. Repetitively I got the following:

Connection to the master has timed out, retrying connection
Closing DMR Network
Opening DMR Network

Obviously that's my issue. But I'm not sure how to rectify it. Any thoughts are appreciated.

Offline K2AMP

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Hotspot, T-Mobile SyncUP Not connecting
« Reply #1 on: May 13, 2020, 01:46:23 pm »
I've been in the IT industry since 1980, before the PC came out. Now, self-employed for almost 16 years. And I've seen my share of unexplainable stuff in tech.

Well, chalk this up under that category. Get back to the house after some appointments and wanted to concentrate on getting this to work. And it's working!!!

WTF! Lol!

Offline ak4tp

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
  • Call Sign: AK4TP
Re: Hotspot, T-Mobile SyncUP Not connecting
« Reply #2 on: March 12, 2021, 11:16:26 am »
I had the same repetetive error, with the connection dropping to TGIF and trying to reconnect.  My hotspot was rock solid when doing only BM, but I changed to DMRGateway with BM and TGIF.  Much rechecking, factory reset, restart.

What solved the problem for me, seemed to be applying the fix which adds the Scripts directory as noted in this Post:

I then did a factory reset, set back up, and carefully "expert" edited the DMR GW file adding Network 4 as Prime_TGIF_Network.
Others have shown a 19 line Network 4 config snippet, and I added that being mindful of Prime in the Name and Address.

System was a new SkyBridge hotspot fully updated to 4.1.4 with Dashboard 20210305.  I tried this testing on Xfinity internet and ATT internet as well.
My background is a C/Unix programmer who has written much client server C code 1988-2006.

What I suspected from a programming side was something not quite right in config of the master socket listening / connecting setup so that somewhere after 40+ seconds the master socket drops, causing a reconnect attempt where it mostly fails then occasionally succeeds.  The TGIF Self Help was showing for the majority of time a Red indication State Unconnected.  I am wondering if some issues "after fix" were solved by improved DMRHosts.txt file(s) with the proper 16 character password and prime host address and Name.  I would love to know for sure just what consistently caused the fail state of drop/reconnect, but I hope this info may help someone in the future.


Related Topics

  Subject / Started by Replies Last post
3 Replies
Last post December 21, 2018, 11:46:23 pm
by Robert K4WZV
2 Replies
Last post May 21, 2019, 11:44:18 am
0 Replies
Last post May 28, 2019, 11:10:41 pm
by N0BTC
0 Replies
Last post November 06, 2019, 10:23:38 am
by N1KK
0 Replies
Last post February 27, 2023, 12:15:40 pm

TGIF Network - Thank God It's Friday!